Author Topic: Compiling/Installing vamp on Mac OSX 10.5  (Read 4200 times)

hoongern

  • Newbie
  • *
  • Posts: 1
    • View Profile
Compiling/Installing vamp on Mac OSX 10.5
« on: August 19, 2009, 09:30:14 »
Hello,

I downloaded the vamp-plugin-sdk-2.0 and ran a make -f Makefile.osx to compile (which completed fine, afaik). I was wondering whether a "install" target exists for Mac OS to install the includes and libs.

Running "make -f Makefile.osx install" returns "no rule to make target 'install'. Stop.", obviously because it's not defined in that Makefile. I tried the regular "./configure && make && make install" as well as "make -f Makefile.in install", but it seems that those are made for Linux, as it dies on "ld: unknown option: -Bsymbolic"

Any ideas?

(I'm actually trying to compile Marsyas with vamp support which failed with just compiling Vamp without "make install" with VAMP_INCLUDE_DIR set to "/Volumes/Storage/dev/vamp-plugin-sdk-2.0" and VAMP_LIBRARY set to "/Volumes/Storage/dev/vamp-plugin-sdk-2.0/src/libvamp-sdk.dylib" in ccmake, with /Volumes/Storage/dev/vamp-plugin-sdk-2.0 being the directory I extracted the tar.gz into)

cannam

  • Administrator
  • Full Member
  • *****
  • Posts: 216
    • View Profile
Re: Compiling/Installing vamp on Mac OSX 10.5
« Reply #1 on: August 26, 2009, 17:09:10 »
I'm afraid there is no OS/X install target for the SDK.  To be honest, when I'm using it on OS/X I generally don't install at all, just add the SDK include paths into my build project much as you described trying to do with Marsyas.  (What went wrong when you tried that?)


Chris