Author Topic: symbol error when loading v1.5  (Read 3430 times)


  • Newbie
  • *
  • Posts: 3
    • View Profile
symbol error when loading v1.5
« on: February 05, 2009, 14:19:13 »

I get a symbol error when trying to load v1.5 with vamp-simple-host :

Vamp::HostExt::PluginLoader: Unable to load library "/tsi/asansol/bmathieu/vamp/": /lib/tls/i686/cmov/ version `GLIBC_2.4' not found (required by /tsi/asansol/bmathieu/vamp/

I'm using a 32bit linux system (debian etch). It used to work with qm-vamp-plugins v1.4

Do you have any idea ?



  • Administrator
  • Sr. Member
  • *****
  • Posts: 250
    • View Profile
Re: symbol error when loading v1.5
« Reply #1 on: March 06, 2009, 17:02:45 »
Sorry to take so long to respond to this one.

The problem is simple enough -- the has been linked against a libc version which has pulled in specific versioned symbols, resulting in a binary that isn't backward compatible against older versions of libc.  I'm pretty sure that there is nothing you can do about this yourselves other than upgrading your version of libc.

I don't know whether it's possible for me to solve this by building in a backward compatible way on a system whose core glibc version is 2.4 -- I will try to investigate this in time for the next point release.  Apologies for the troubles.