Author Topic: Vamp plugins not loading in Audacity  (Read 208 times)

meowsqueak

  • Newbie
  • *
  • Posts: 1
    • View Profile
Vamp plugins not loading in Audacity
« on: January 19, 2017, 01:34:36 »
I am trying to use the CQ Vamp plugin with Audacity, however I am not able to get to a point where Audacity shows the plugin in the UI.

I am using Ubuntu 14.04.5 with Audacity 2.1.2 (fresh install from PPA). I have tried both the pre-compiled 1.1 (64bit) from the website, and compiling it myself. I have placed the cqvamp.so, cqvamp.n3 and cqvamp.cat file in ~/.vamp. I have also tried ~/vamp and /usr/local/Iib/vamp. I have also tried setting VAMP_PATH.

In all cases, Audacity does not show the plugin in the Add / Remove Plugins dialog. However when opening audacity with strace -eopen I see that the file cqvamp.so is opened three times when the dialog is opened, so there's some detection of the .so file. Unfortunately Audacity shows no relevant messages in dialogs, or on stderr or stdout, so I'm at a loss to know why it isn't recognising the plugin beyond opening the .so.

cannam

  • Administrator
  • Sr. Member
  • *****
  • Posts: 263
    • View Profile
Re: Vamp plugins not loading in Audacity
« Reply #1 on: January 19, 2017, 10:21:32 »
Hi there -- I believe this plugin doesn't show up because Audacity has no way to display any of its outputs. Audacity only shows those plugins that have at least one output that can be displayed on a label track -- it can't display grid output from Vamp plugins, and all of the CQ outputs are grids.

That is the way it used to work anyway, I haven't checked the code very recently.