Author Topic: Vamp Plugins on Ubuntu Linux 64 bit  (Read 7494 times)

Luctor

  • Newbie
  • *
  • Posts: 8
    • View Profile
Vamp Plugins on Ubuntu Linux 64 bit
« on: October 19, 2007, 09:47:45 »
I've recently got a new PC (AMD Athlon(tm) 64 X2 Dual Core Processor 4400+) and installed Ubuntu 7.10 amd64 on it.
I'v managed to compile and install Sonic Visualiser from SVN on it using vamp-sdk 1.1; but i have some trouble running some plugins.

Aubio plugins work fine, I've converted a Suse RPM using alien and it works ..

Mazurka plugins, will compile but when run I get an error message
Code: [Select]
WARNING: FeatureExtractionPluginFactory::getPluginIdentifiers:
Failed to load library /usr/lib/vamp/vamp-mazurka.so: /usr/lib/vamp/vamp-mazurka.so:
undefined symbol: _ZTIN4Vamp17PluginAdapterBaseE
Maybe the vamp-sdk 1.1 is the problem here ???

QM plugins
Now it gets ugly ... ;)
The plugins I use most often are not opensource .. so I have no way to recompile them
Code: [Select]
WARNING: FeatureExtractionPluginFactory::getPluginIdentifiers:
Failed to load library /usr/lib/vamp/qm-vamp-plugins.so:
/usr/lib/vamp/qm-vamp-plugins.so: verkeerde ELF-klasse: ELFCLASS32
(verkeerde ELF-klasse translates to wrong ELF-class}
I sort of expected that to happen.
No I would like to get in contact with the QM guys (and girls ?) to kindly ask them to compile a 64bit version, but the website http://www.elec.qmul.ac.uk/digitalmusic/ is unresponsive. I noticed this happens a lot ...

Does anyone have a solution ?

Rob



cannam

  • Administrator
  • Full Member
  • *****
  • Posts: 229
    • View Profile
Re: Vamp Plugins on Ubuntu Linux 64 bit
« Reply #1 on: October 19, 2007, 16:30:08 »

What does "ldd vamp-mazurka.so" say?  It may be picking up the wrong version of the library.  Also, the 1.1 SDK had an incorrect soname for the installed plugins which the 1.1b SDK corrects, so it might be worth updating, although I wouldn't expect this to cause the error you quote.

If in doubt, try using static linkage for the SDK libraries when linking the plugin (i.e. -Wl,-Bstatic -lvamp-sdk -Wl,-Bdynamic in the link line).  Although plugins made with one of the 1.0 and 1.1 SDKs are compatible with hosts made with the other, that obviously doesn't help if the plugins themselves refuse to load because they can't find the dynamic library that matches the headers they were compiled with!

With regard to the QM plugins, we (I'm one of the QM guys) have had requests for a 64-bit build before, and hope to be able to come up with something fairly soon.  I'm afraid there is no workaround; a 64-bit host simply can't load a 32-bit shared library, full stop.


Chris

Luctor

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Vamp Plugins on Ubuntu Linux 64 bit
« Reply #2 on: October 19, 2007, 17:15:11 »
Here it is

ldd /usr/lib/vamp/vamp-mazurka.so
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00002b0527b6d000)
        libm.so.6 => /lib/libm.so.6 (0x00002b0527e78000)
        libc.so.6 => /lib/libc.so.6 (0x00002b05280fa000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00002b0528455000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)