Author Topic: problems with windows hostsdk msvc binaries  (Read 3339 times)

maep

  • Newbie
  • *
  • Posts: 3
    • View Profile
problems with windows hostsdk msvc binaries
« on: June 23, 2009, 13:24:01 »
Hi, just to drop a note, in case someone has similar issues:

I had considerable problems with the precompiled windows host msvc binaries. Linking to the debug lib file caused linker errors, and the release build wouldn't discover my installed plugins.
Now I build everything from source and it works. I use visual studio 2005 on vista. This is just a hunch, but are the libs build with multibyte or unicode support?

-- maep

cannam

  • Administrator
  • Full Member
  • *****
  • Posts: 220
    • View Profile
Re: problems with windows hostsdk msvc binaries
« Reply #1 on: June 25, 2009, 15:30:40 »
Hm, that's unfortunate.  I have to admit that these particular libraries have not been well tested.

I don't know the certain answer to your question, but I think it's unlikely that they would have been a Unicode build since support for Unicode builds was only recently added to the SDK in Subversion.  I think.  (Are you building a released version in Unicode mode?)


Chris

maep

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: problems with windows hostsdk msvc binaries
« Reply #2 on: July 10, 2009, 19:14:35 »
Yes, I've build it with Unicode support.
One other thing: I had crashes when my host application exits. The reason was that in my host application, the plugins were implicitly deleted by the CRT after return of the main method. As it turned out, plugins must be deleted before return of the main method. In my case, the plugin-loader was deleted be the CRT before the plugin's destructors are called.